Computer Requirements

Computer Requirements for Online Courses

Here at Campbellsville University, we use Moodle to provide password-protected online courses.  The following are the computer and internet requirements you will need for Moodle to work properly. 

Before beginning online courses, please ensure that your computer is equipped to access your course.

Minimum Requirements:

     Mac        OS X 10.6 or higher

  Windows     Vista, 7, or 8
  Browser    Internet Explorer 9,   Firefox 14,   Google Chrome 20,   Safari 5,   Opera 9
 
  Internet    Dial-up (load times may be lengthy), DSL, or cable

  Adobe Reader     Updated version

  Flash Player     Updated version

Mozilla Firefox works best with Moodle.  Other browsers may not support all functionality, such as online quizzes. 

You may need to add an exception for your Moodle website to your browser's pop-up blocker. We recommend that you disable any pop-up blockers in third-party toolbars that may be installed in your browser. 

It is also recommended that you use a faster internet connection, like DSL or cable, for the best user experience.